why stepper motor doesn't move?

Discuss Stepper motors, Drivers, Controllers, GUI's and related Accessories here.
Fikadu
Posts: 3
Joined: Tue May 29, 2018 5:42 pm

why stepper motor doesn't move?

Postby Fikadu » Tue May 29, 2018 6:11 pm

Hello every one.
I am just starting to use a sepper motor PKP264D28A-R2EL with a driver CVD228B-K. Because I am doing as software guy, no much idea about hardware design. while testing by Connecting +15V to pin 1 and pin 3 of the driver; CW to pin 2 and CCW to pin 4, the motor doesn't move at all. The pulse mode is configured as one pulse for the fact that active high or low is applied to CCW for direction. Note that a 24V DC supply and some others neccessary connections are connected according to the operation manual, keeping AWO,CS,ALM, and TIM unconnected. My schematic for pulse source connecation and the pluse generated are attached here with. would you look in to it and show me what wrong I did.
Thank you a lot.
Attachments
schematic.jpg
schematic.jpg (25.23 KiB) Viewed 542 times
pulse.jpg
pulse.jpg (44.87 KiB) Viewed 542 times

om_tech_support_AC
Posts: 46
Joined: Tue Jan 03, 2017 2:53 pm

Re: why stepper motor doesn't move?

Postby om_tech_support_AC » Wed May 30, 2018 7:44 am

Hi Fikadu,

The input voltage specification for the CW input and CCW input is 5 VDC. If the voltage exceeding 5 VDC is applied, connect an external resistor R1 so
that the input current becomes 7 to 20 mA. Since you are using 15 VDC you'll need the external resistor to limit the current. For more information about the CVD228BR-K please refer to the link below.

http://www.orientalmotor.com/products/p ... pdf#page=8

Fikadu
Posts: 3
Joined: Tue May 29, 2018 5:42 pm

Re: why stepper motor doesn't move?

Postby Fikadu » Thu May 31, 2018 12:18 am

Thanks a lot.
Now, It is perfectly working


Return to “Stepper Motors and Controls”

Who is online

Users browsing this forum: No registered users and 6 guests